[PLUG] Chroot and wifi

John Jordan johnxj at comcast.net
Sat Jan 21 08:32:58 PST 2006


On 20 Jan 2006, at 22:45, Jason R. Martin wrote:

> > As Ubuntu-64 Breezy boots it displays a ton of stuff before it gets
> > to the graphical interface. I noticed the following and decided it
> > might be significant, especially since it refers to /proc --
> >
> > mount: special device /media/floppy0 does not exist
> > /home on /chroot/breezy/32bits/home type none (rw,bind)
> > /tmp on /chroot/breezy/32bits/tmp type none (rw,bind)
> > /dev on /chroot/breezy/32bits/dev type none (rw,bind)
> > /proc on /chroot/breezy/32bits/proc type none (rw,bind)
> > /media/cdrom0 on /chroot/breezy/32bits/media/cdrom0 type none
> > (rw,bind)
> > /usr/share/fonts on /chroot/breezy/32bits/usr/share/fonts type none
> > (rw,bind) [FAIL] (in red)
> >
> > I'm not sure if the lines starting with / are a continuation of the
> > floppy line at the start, or if the [FAIL] at the end refers to just
> > the fonts line or to all of the above. In other words, are all those
> > lines things that are supposed to be mounted? And if so, did they?
> > Beats me. :(
> >
> > Note that the lines above following the floppy line were never there
> > before installing chroot. But even I am smart enough to figure out
> > that that makes sense.
> >
> > Now, as to whether /proc and /sys mounted in chroot, I typed from a
> > command line (guessing at the proper syntax):
> >
> > dchroot -d mount
> >
> > And got:
> >
> > proc on /proc type proc (rw)
> > sysfs on /sys type sysfs (rw)
> >
> > So my guess about the proper syntax was probably right. (Damn!
> > I'm gettin' this stuff!) But I'm not sure exactly what the results
> > mean.
> 
> Actually I'm not sure either, since you're in a chroot environment. An
> easy test though would be to run "ls <chroot prefix>/proc" and see if
> there is anything in there.  It should be very similar to what is in
> /proc in your 64-bit environment.

OK, there is a /chroot/breezy/32bits/proc folder and it has lots of 
stuff in it. There are folders with names like acpi, asound, bus, 
driver, fs, ide, irq, net, scsi, self, sys, syvipc, tty -- and there are a 
ton of folders with numbers, most of which have close to the same 
contents.

> Okay, time to insult your intelligence, by asking if you can access
> the internet from your wireless *outside* the chroot, i.e. with a
> normal 64-bit app.

Insulting my intelligence is not a possibility. There is no 
intelligence to insult. :(

As to the question, I already did some of that at the university 
yesterday. I can't do more right now because there is no wifi here 
at home -- I'm all ethernet in the house. But I'm going to go to a 
class at Freegeek at 1:00 this afternoon, so I can try stuff there.

Normally I am in 64-bits. The only programs installed in chroot 
(other than what chroot installed) are Firefox32 and its Flash 
plugin, RealPlayer and Adobe Reader 7.0. So unless I specifically 
run one of those apps, everything else is running in 64 bits. Each of 
those programs has a special launch menu item that I added to the 
Gnome Applications menu, using dchroot -d <application> as its 
launch command. Thus, there are two launch items for Firefox, one 
I labeled (old) and the other (32bits). That way I can tell which one I 
am running.  

Yesterday, while connected to pub.net at the university, I found 
that programs installed in the normal 64-bit environment, including 
Firefox, could get out just fine as they always did before. I could 
look at mail with Evolution or Thunderbird, browse with Firefox chat 
with XChat, etc. It was only when I launched 32-bit Firefox from 
chroot that I was unable to get out.

What you asked already occurred to me yesterday, except I didn't 
think of pinging something. But I wanted to find out if the problem 
was 32-bit Firefox or if it was the entire chroot environment that 
was blocking me. So I launched Synaptic32 thinking I would install 
some other internet app in chroot and see if it could get out. Well, I 
got the answer when Synaptic32 was unable to get to the 
repositories. I tried everything, even the extra repositories that I 
have listed. Synaptic32 couldn't go anywhere. But remember that I 
installed 32-bit Firefox, RealPlayer and Adobe Reader 7.0 in chroot 
while at home, where my net connection is via ethernet to the hub, 
router and cable modem. Thus, I pretty well proved that it is the 
entire chroot environment that can't find the wireless. 

> If so, then try to eliminate DNS issues, perhaps with just ping
> (again, inside the chroot).  Try accessing an IP address.  If that
> works but a hostname doesn't, check /etc/resolv.conf inside the
> chroot.  There's more you could check after that if it still doesn't
> work, but I'm getting too tired.

As to DNS, I wish I had thought to try pinging something by its IP 
address when I was at PSU yesterday, but I did not, so that 
remains a question to be answered. I can do that later today at 
Freegeek.

> Personally, I still think you're playing with fire and life would be
> much simpler if you just installed a 32-bit distribution.  But that's
> your choice ;-)

You are totally correct. But it was the right decision for me. I 
bought this 64-bit laptop because 1) I needed a laptop for school 
and 2) I really wanted to learn Linux. I had tried Corel Linux several 
years ago when it was all the rage but never did more than fiddle 
with it. All the experience did for me was let me know that learning 
Linux was not going to be a snap, and make me a lot of money on 
the Corel stock that I forturnately sold before it tanked. :)

>From past experience with computers and software, trial by fire is 
the way to learn if you really want to learn something. Putting 64-
bit Linux on a laptop as its only OS should do the trick. So far I 
think I made the right decision. The pain was expected. Each time 
I face a challenge I move forward. In the meantime, the computer is 
functional for my school needs. So don't worry -- I will not abandon 
Linux even if it turns out I can't get chroot to see the wifi. I am 
confident it can be done, however. That is, as long as PLUG 
members don't get too annoyed at my constant stupid questions. :(

Thanks for the suggestions so far. :)



More information about the PLUG mailing list