[PLUG] Postfix body checks - inbound only?

Keith Morse kgmorse at mpcu.com
Thu Aug 28 22:43:01 UTC 2003


On Thu, 28 Aug 2003, Steven Raymond wrote:

> Is there any way to make Postfix not perform the body_checks (perhaps any
> anti-UCE checks) for local users sending mail(particularly root)?
> 
> Here's my current problem.  I have a cron job that (with pluggers' help)
> emails me every time Postfix rejects a message for any reason.  So a spam
> comes in which is rejected for a body check reason "e.g. buy v1agr@ or
> die!!".  No problem yet.  This text gets logged as normal in
> /etc/log/maillog with the offending line, including the offensive text. 
> My script then tries to email the log exerpt (grep 'reject'
> /etc/log/maillog) as root but is then bounced by Postfix again, because
> -suprise!- it has spam content.
> Not the end of the world, but I would like to exempt root or certain local
> users, from being subject to the body_checks filter.  Or any other
> workaround that may fix it.  Note that I already have a white list file
> called permit-domains ala Rich & Ed's suggestions.  That works great
> _except_ that it does not seem to bypass the body_checks file- they still
> happen regardless of the whitelist permission.

the only way I can think to do this is by running a second instance of 
postfix.   There is a step by step process listed at 
http://www.advosys.ca/papers/printable/postfix-instance.html
that will accomplish this.  That way you can have two differenct main.cf 
files for behavioural modification.






More information about the PLUG mailing list