[PLUG] USB Mass Storage errors

Russell Senior seniorr at aracnet.com
Mon Sep 13 12:20:03 PDT 2004


I've got a 200 Gig IDE drive in an external enclosure, used as a
backup device.  I am getting occasional lockups during particularly
intense rsyncs, and just had my first on 2.6.8.1 last night.
Afterwards, I began getting messages like:

   scsi4: ERROR on channel 0, id 0, lun 0, CDB: Read (10) 00 00 00 6a 8a 00 00 04 00
   Current sdb: sense key Medium Error
   Additional sense: Unrecovered read error
   end_request: I/O error on device sdb1, logical block 27273

and on and on for different blocks.  I vaguely recall hearing about
IDE devices that could screw up the checksums on sectors if shut down
abruptly, and subsequently assign read errors to them as a result.  Is
that a likely scenario here, and if so is there anything I can do
about it, like a reformat.  The smartutils stuff doesn't (or didn't
when I tried a while ago) seem to work across the USB-to-IDE bridge,
but I'd be willing to jack the thing directly into an IDE port if I
can fix it.

The disk is, from what I can tell from the logs:

  scsi4 : SCSI emulation for USB Mass Storage devices
    Vendor: Maxtor 6  Model: Y200P0            Rev:  0 0
    Type:   Direct-Access                      ANSI SCSI revision: 02
  SCSI device sdb: 398297088 512-byte hdwr sectors (203928 MB)
   sdb: sdb1


-- 
Russell Senior         ``I have nine fingers; you have ten.''
seniorr at aracnet.com




More information about the PLUG mailing list