[PLUG] Uncooperative NICs

Paul Mullen pem at nellump.net
Thu Sep 16 11:33:01 PDT 2004


I've tried in vain for some time now to get my old dual-proc SuperMac
S900 to work properly with more than the OEM 10 Mb NIC installed. I've
had relatively little difficulty with Debian 'unstable' on this box. It
successfully boots either 2.4 or 2.6 kernels. Networking fails in
various ways when I install a second NIC. Usually, the installed devices
can still be configured, but they just don't respond to any attempts to
communicate over the network. For instance, attempting to request a DHCP
lease fails as if there were no other hosts on the network.

I've tried two different NICs: a 100Mb LinkSys and a gigabit
RealTek-based model. Both exhibitied similar behaviors.

When booted from the 2.4.25-powerpc-smp-pmac kernel, I can get the
gigabit card to be recognized, and can configure the device, but at the
first sign of network activity (pings from another machine, in this
case), the SuperMac essentially locks up, spewing "too much work at
interrupt" down the monitor.

When booted from the 2.6.8-powerpc-smp kernel, I don't even have to have
a second NIC installed to cause problems. I can probe in the r8169
RealTek gigabit driver (which I don't think I *should* be able to do
when the card isn't even installed), which immediately kills the OEM NIC
-- it just won't configure any longer. Attempting to remove the r8169
module freezes up the machine.

I've also tried shuffling around the PCI cards. I removed both the ATA
and video cards, leaving only the gigabit NIC in PCI slot #1. With this
arrangement, I was able to probe in the appropriate modules for both the
built-in NIC and the PCI NIC ('mace' and 'r8169', respectively), and was
also able to successfully configure both.

Then things got weird. I only had one Ethernet cable to play with, so I
would alternate back and forth trying to get one or the other to talk to
my PC. The built-in NIC worked fine. It would respond to pings and I
could SSH in. The PCI (gigabit) NIC would not work at all. However, if I
pinged the IP address assigned to the PCI NIC while the cable was still
plugged into the built-in NIC, it would happily pong back. Very odd. It
seems as if somehow both eth0 and eth1 are being assigned to the
built-in NIC, even though by most signs this is clearly not the case.

I'm pretty much out of ideas here. I'd rather avoid having to break down
and buy an x86 box, but if I have to... Any ideas?


Paul




More information about the PLUG mailing list