[PLUG] Digital Camera - Mount Windows partition?

Russell Senior seniorr at aracnet.com
Sun Sep 26 15:56:02 PDT 2004


>>>>> "Rich" == Rich Shepard <rshepard at appl-ecosys.com> writes:

Rich>    3.) Run, in order: make dep; make clean; make bzImage; make
Rich> modules; make modules_install;

This has changed in 2.6.  You don't need the "make dep" anymore.  You
do:

  "make <config-of-your-choice> ; make ; make install ; make modules_install"

where <config-of-your-choice> for me is usually "oldconfig", which
will use as much of the old .config (which you can copy from an
appropriate location, say /boot/config-<old-kernel-version> to .config
in the source tree root).  If you want to change anything, then you
can do a "make menuconfig" (or whatever) before proceeding.  The "make
clean" is superfluous in most cases.  If you want to be sure you are
starting from a really clean tree, do a "make mrproper", but be sure
to copy your valuable .config files somewhere else so it doesn't get
stomped on.

The semi-colon command separators aren't necessarily intended
literally.  You need to be root to do the last two.  Some people use
command compositions that cause the chain to halt on abnormal
terminations, although I usually just do the "make oldconfig" and any
adjustment manually.  FWIW, this is what I will do when 2.6.9 arrives:

  $ cd /src
  $ tar xjvf /src_archive/kernel/v2.6/linux-2.6.9.tar.bz2
  $ cd linux-2.6.9
  $ cp /boot/config-2.6.8.1 .config
  $ make oldconfig

if necessary:

  $ make menuconfig 

then:

  $ make -j4 ; su -c 'make install ; make modules_install'

where the -j4 make option controls the number of concurrent jobs and
is appropriate for dual-proc SMP boxes.  It'll pause for a root
password when it hits the "su".  Then I'll modify /boot/grub/menu.lst
to add a stanza for 2.6.9 and reboot.

I don't use initrd's, so if you are, there is some additional
incantation required that I don't know much about.

Getting back on the camera problem, I think I'd look for why you can't
mount the camera as a USB Mass Storage device, rather than punt
immediately to the NTFS route.  You don't want yourself to be
dependent on windows.  I suspect maybe an absence of SCSI support?
Have you shown us the results of an "lsmod" or your .config.

At the clinic last weekend I solved someone's problem with a USB thumb
drive thingie on Debian, which boiled down to the right modules not
getting loaded.  The whole thing got solved by looking at his lsmod
and his .config file to see if/how the support was compiled.  He had a
kernel with the config information readable in /proc/config.gz (or
very much like that), which made things easy.

-- 
Russell Senior         ``I have nine fingers; you have ten.''
seniorr at aracnet.com




More information about the PLUG mailing list