[PLUG] odd date command behavior for the starting Daylight time in a year

Dale Snell ddsnell at frontier.com
Wed Sep 25 22:54:34 PDT 2013


On Wed, 25 Sep 2013 22:06:33 -0700
website reader <website.reader3 at gmail.com> wrote:

> To the KPLUG community:

KPLUG?

PLUGH!

> I got "invalid data" warnings for all the March dates on the shell
> script file, but changing the time to 03:00:00 fixed this problem.  Is
> something wrong with the tzfile or ???
> 
> The problem occurred on my Ubuntu machine when checking daylight
> savings time EPOCH values for the years 2010 to 2015.
> 
> I am curious to see if this occurs on other machines?
> 
> Randall

------>%======== snip! ========%<------

Just tried your script, got the same problem.  I tried subtracting one
day from all the March dates and everything worked.

Those March days are all Daylight Saving Time switchover days, aren't
they?  (If they're not, I'm going to look really stupid...)  There is
no 2:00AM hour on those days, thus the dates really are invalid.

--Dale

--
"IT'S THE END OF THE WORLD!  Or the beginning.  Hmph.  End, begin,
all the same.  Big change.  Sometimes good.  Sometimes bad."
    -- Aughra, _The Dark Crystal_



More information about the PLUG mailing list